Benvenuto!

Questo è il forum ufficiale dell'Associazione Odoo Italia. Dopo esserti registrato potrai partecipare ponendo domande o rispondendo a quelle esistenti. Non scordarti di compilare il tuo profilo e consultare le linee guida prima di iniziare a scrivere.

0

2
Avatar

Alex Comba

--Alex Comba--
1355
| 2 0 5
Torino, Italia
--Alex Comba--

Laureato in Matematica all'Università di Torino, FLOSS entusiasta, è tra i fondatori del LUG della sua città natale e nel 2007 fa dello sviluppo software il suo mestiere per approdare ad OpenERP nel 2012. Membro delegato Odoo Community Association, è altresì membro di diversi PSC all'interno della stessa associazione. Felice papà di due piccoli Ctrl+C Ctrl+V!

Alex Comba
Il 13/01/21, 16:58

Dopo aver clonato il repo, prima di fare "git checkout 12.0", sei entrato nella cartella OpenUpgrade?

Step da seguire:

  • git clone https://github.com/OCA/OpenUpgrade.git

  • cd OpenUpgrade

  • git checkout 12.0


La tua risposta

0

si certo, l0unica cosa che ho fatto ho fatto git ..... openupgrade nella cartella root, poi ho copiato

la cartella è dentro /odoo

sono entrato picchè

nb ho anche questo errore

Successfully built ebaysdk psutil
Installing collected packages: requests-toolbelt, isodate, defusedxml, cached-property, attrs, appdirs, zeep, psutil, polib, odoorpc, num2words, Jinja2, gevent, ebaysdk
  Attempting uninstall: psutil
    Found existing installation: psutil 5.5.1
ERROR: Cannot uninstall 'psutil'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.



La tua risposta

0

a quanto pare ero stato troppo frettoloso, non avevo installato le dipendenze,

ho commentato il file sopra indicato nell'errore e ho installato le dipendenze adesso ho :

git checkout 12.0
error: Your local changes to the following files would be overwritten by checkout:
        requirements.txt
Please commit your changes or stash them before you switch branches.
Aborting



La tua risposta

0
Avatar

Alex Comba

--Alex Comba--
1355
| 2 0 5
Torino, Italia
--Alex Comba--

Laureato in Matematica all'Università di Torino, FLOSS entusiasta, è tra i fondatori del LUG della sua città natale e nel 2007 fa dello sviluppo software il suo mestiere per approdare ad OpenERP nel 2012. Membro delegato Odoo Community Association, è altresì membro di diversi PSC all'interno della stessa associazione. Felice papà di due piccoli Ctrl+C Ctrl+V!

Alex Comba
Il 14/01/21, 08:08

Sono state apportate delle modifiche al file requirements.txt. Come ti suggerisce git, se non ti servono: abbandonale!


La tua risposta

0

ho commentato psutil perchè dava l'errore sopra riportato
altrimenti non riuscivo a installare tutte le altre dipendenze

comunque provo ,


Enrico


La tua risposta

0

decommentato e adesso risponde .

Grazie




La tua risposta


0

ma l'importazione non riesce .

2021-01-14 15:09:31,732 1072 INFO ? odoo: database: default@default:default
2021-01-14 15:09:31,736 1072 INFO ? odoo.sql_db: Connection to the database failed



La tua risposta

0

risolto anche questo, sono coglione mettevo il nome del database sbagliato .

adesso vedo se torna tutto.

Grazie



La tua risposta


0

ok pensavo di avr fatto tutto bene, ma evidentemente no

quando arrivo a caricareil vecchi database della 11 sulla 12 ho

Warning, your Odoo database manager is not protected.
Please set a master password to secure it.
Database restore error: ERRORE: la colonna res_lang.week_start non esiste LINE 1: ...active","res_lang"."time_format" as "time_format","res_lang"... ^

il comando di upgrade sembra andare a nuon fine, ma poi non ho i dati dentro odoo.

c'è Michael admin

Enrico



La tua risposta

0

questo errore l'ho risolto importando il dabase non co copy ma con moved


La tua risposta

Resta informato

Informazioni sulla comunità

Forum ufficiale dell'Associazione Odoo Italia Leggi le linee guida

Strumenti di richiesta

58 follower

Statistiche

Richiesta del: 13/01/21, 16:41
Vista: 424 volte
Ultimo aggiornamento: 14/01/21, 18:36